The application has been operating in closer alignment with the expected performance levels for the past 2 hours. We have additional lightly disruptive maintenance that has been scheduled for this evening. We are continuing to closely monitor all systems.
Posted Mar 03, 2026 - 16:54 CST
Monitoring
We have implemented mitigations that are showing good initial signs of stabilizing the system. We are continuing to investigate and address additional findings.
Posted Mar 03, 2026 - 14:47 CST
Investigating
We are currently investigating issues with errors and slowness impacting the application.
Posted Mar 03, 2026 - 12:21 CST
This incident affected: ChamberMaster/MemberZone Database, Integrated Website Modules, SmartCMS Websites, Staff App for iOS and Android, and API.